Overview

This plugin aims to simplify management of Eclipse plugin artefacts interdependency. It allows to track required plugin version, and also to automatically generate feature and site update distribution. Flexibility is attained through the declaration of user-defined Ant filter that allows to use custom replacement strings in the templates.

In the future, maven-eclipse-plugin-plugin may also support fs/ssh/ftp deploiement of generated artifact archives. We're also working on a different build mode that will allow to generate eclipse plugins from a stated dependency instead of bundling it as a runtime library.

Please refer to this document for a complete list of features.

Versions

Latest version available for download is 0.3.1. It works with Eclipse 3.0, and should also with 2.x stream builds. Also please note that the PDE Plugin doesnot support OSGI Bundles yet.

Installing

To install the plugin automatically, please add the http://mevenide.codehaus.org/repository to your maven.repo.remote parameter. And use the plugin:download maven goal to install the plugin.

	maven -DartifactId=maven-eclipse-plugin-plugin -DgroupId=mevenide -Dversion=0.3.1 plugin:download