Netbeans Module page

This project allows to open and work with Maven projects in the Netbeans IDE. Mevenide currently supports NetBeans 5.0.

Netbeans 5.0

Mevenide for the Netbeans 5.0 version works with Maven 1.0.2 and contains these features .

You can download the 1.0 release. It was tested with Maven 1.0.2 and Netbeans IDE 5.0 final. (4.1 should also work with some exceptions, but we encourage you to upgrade to 5.0)

Reasonable effort is made to have it always working with the latest development builds of Netbeans 5.5. Please note that the grammar module (editor completion for maven xml files) in 1.0 release zip will work with the 5.0 and later builds but to get it working with 4.1 you need the old 4.1 mevenide-grammar nbm .

If you don't have Netbeans yet, Download NetBeans!

Maven 2.0 support

Maven2 support has been released. It can be used simultaneously with the Maven1 integration or on it's own. See available features and download instructions It works only in Netbeans 5.0 and later